Unbeantwortete Themen | Aktive Themen Aktuelle Zeit: Mo 14. Jun 2021, 01:02



Auf das Thema antworten  [ 3 Beiträge ] 
 Einbau eines Bluetooth-Moduls in den 900A 
Autor Nachricht
Benutzeravatar

Registriert: Di 19. Okt 2010, 12:38
Beiträge: 542
Wohnort: Oberösterreich
EEE PC: Ja
Modell: Eee PC 901GO
OS: Linux, anderes
Modell: EEE PC 900A, EEEPC R101D
Mit Zitat antworten
Beitrag Einbau eines Bluetooth-Moduls in den 900A
Derzeit gibt es bei Pollin ein sehr preiswertes BT-Modul. Da mein EEEPC 900A kein Bluetooth eingebaut hat, aber eines auf dem Mainboard vorgesehen ist, lag die Idee nahe, ihn versuchsweise mit diesem Modul nachzurüsten. Der originale Steckverbinder ist auf dem Mainboard nicht bestückt und es fehlen auch zwei 0Ω-Widerstände in den USB-Zuleitungen zu diesem, beides ist aber kein Problem, im Gegenteil, dadurch fällt das Einlöten der Anschlusslitzen des Modulkabels etwas leichter. Am BT-Steckverbinder gibt es eine Versorgungsspannung von gemessenen 3,1V, das Modul ist von 3,0...3,6V spezifiziert, auch das sollte also passen.

Recht groß ist das Ding nicht - Feingefühl und gute Augen sind angesagt. Die Litzen des Modulkabels sind mit einem schwarzen Gewebeklebeband umwickelt, dessen Entfernung eine etwas heikle Geduldsarbeit ist. Die Litzen haben inklusive Isolierung einen Durchmesser von nur 0,4mm - also ist Vorsicht nötig, nichts zu beschädigen. Hat man das klebrige Zeug endlich weg, schneidet man den 4-poligen Stecker ab und es geht ans Abisolieren der 5 Litzen, was sich auch nicht ganz einfach gestaltet. Anschließendes Verzinnen und Ablängen der blanken Enden auf etwa 1,5mm Länge ist dagegen ja schon die reinste Erholung :-). Einen feinen Lötkolben braucht man für das Einlöten auf dem Mainboard, gute Augen oder zumindest eine passende Brille ebenfalls. Lötflußmittel gibt es als Filzstift, es ist auch nicht falsch, wenn man so etwas zur Verfügung hat. Ein kleines Stück doppelseitiges Schaumstoffklebeband sollte man haben oder besorgen, um den Print auf dem Mainboard zu befestigen.

Ich habe das Anschlusskabel mit einem kurzen Stück Schrumpfschlauch zusammengefasst, sieht gut aus und entlastet die Anschlüsse auf dem winzigen Anschlussstecker am BT-Modul. Dieses Bild zeigt die Verdrahtung, die roten Ziffern geben die Pin-Nummer auf dem Modulstecker an:

Dateianhang:
900A-BTmodul.jpg
900A-BTmodul.jpg [ 149.35 KiB | 9365-mal betrachtet ]

Da ich den 900A mit Linux (Mint) betreibe, ist der erste Bick nach dem Einschalten auf die erkannten USB-Geräte, und das sieht ja schon mal gut aus:

***************

franz@Asus-900A-fp:~$ lsusb
...
Bus 005 Device 002: ID 18e8:6260 Qcom
...
franz@Asus-900A-fp:~$

***************

wenn auch der Kommentartext des Herstellers etwas schlicht ausgefallen ist. Auch dmesg macht einen hoffnungsfrohen Eindruck:

***************

franz@Asus-900A-fp:~$ dmesg
...
[ 3.157038] usb 5-1: New USB device found, idVendor=18e8, idProduct=6260
[ 3.157052] usb 5-1: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[ 3.157061] usb 5-1: Product: Bluetooth USB
[ 3.157070] usb 5-1: Manufacturer: Broadcom Corp
[ 3.157078] usb 5-1: SerialNumber: 000DF0A3131A
...
[ 6.938644] Bluetooth: HCI device and connection manager initialized
[ 6.938670] Bluetooth: HCI socket layer initialized
[ 6.938682] Bluetooth: L2CAP socket layer initialized
[ 6.938703] Bluetooth: SCO socket layer initialized
...
[ 8.383840] usbcore: registered new interface driver btusb
[ 8.841395] Bluetooth: BNEP (Ethernet Emulation) ver 1.3
[ 8.841406] Bluetooth: BNEP filters: protocol multicast
[ 8.841434] Bluetooth: BNEP socket layer initialized
[ 8.916451] Bluetooth: RFCOMM TTY layer initialized
[ 8.916483] Bluetooth: RFCOMM socket layer initialized
[ 8.916511] Bluetooth: RFCOMM ver 1.11
...
franz@Asus-900A-fp:~$

***************

Der Bluetooth-Manager blueman erkennt den Adapter und das Pairing und der Verbindungsaufbau mit meinem BT-Headset klappt anstandslos:

Dateianhang:
Screenshot26.png
Screenshot26.png [ 29.83 KiB | 9365-mal betrachtet ]

Ein Wermutstropfen stellt sich später ein: hin und wieder ist der BT-Adapter beim Hochfahren des EEE ausgeschaltet, das Einschalten über den Bluetooth-Manager klappt nicht richtig. Der Adapter wird in so einem Fall erst nach einem Neustart richtig eingebunden, funktioniert dann aber problemlos. Das Audiosystem pulseaudio braucht immer einen Neustart um das Headset zu akzeptieren, aber das ist ebenfalls ein Problem des Linuxsystems, da wird noch Nacharbeit nötig sein.

Gruß Franz

edit: der Print des 900 sieht sehr ähnlich aus - dort könnte es genauso funktionieren ...

_________________
Linux Mint 17 Xfce (Ubuntu's Unity wollte ich nicht) - passt gut für den 901GO
Aus purer Nostalgie auch einen 900A ersteigert und das Mainboard getauscht
und weil zukunftssicherer (64bit-CPU) noch zusätzlich einen R101D zugekauft


Mo 1. Dez 2014, 20:08
Profil Website besuchen
Benutzeravatar

Registriert: Di 19. Okt 2010, 12:38
Beiträge: 542
Wohnort: Oberösterreich
EEE PC: Ja
Modell: Eee PC 901GO
OS: Linux, anderes
Modell: EEE PC 900A, EEEPC R101D
Mit Zitat antworten
Beitrag Re: Einbau eines Bluetooth-Moduls in den 900A
Nach einiger Erfahrung mit dem BT-Modul kann ich berichten, dass die beschriebenen Fehler offensichtlich auf die nicht optimale Unterstützung durch das Betriebssystem (Linux Mint 17) zurückzuführen sind. Mit dem schon älteren Ubuntu 10.04 LTS klappt dagegen alles, auch die komplette Einbindung meines nicht mehr ganz taufrischen Mobiltelefons Nokia 2720, mit der die neueren Ubuntus und Linux Mints ebenfalls nicht vollständig zurechtkommen ...

Gruß Franz

_________________
Linux Mint 17 Xfce (Ubuntu's Unity wollte ich nicht) - passt gut für den 901GO
Aus purer Nostalgie auch einen 900A ersteigert und das Mainboard getauscht
und weil zukunftssicherer (64bit-CPU) noch zusätzlich einen R101D zugekauft


Mi 17. Dez 2014, 18:42
Profil Website besuchen

Registriert: Mi 2. Jan 2019, 19:14
Beiträge: 1
EEE PC: Ja
Modell: Eee PC 900A
OS: Linux, anderes
Mit Zitat antworten
Beitrag Re: Einbau eines Bluetooth-Moduls in den 900A
Salü Franz,

ich habe bzgl. der Pins bzw.der Lötpunkte eine Frage: sind die Pins 3+4 an den oberen oder unteren Lötpunkten angelötet oder evtl. an beiden, also gebrückt (Blickrichtung oben/unten so wie Dein Photo eingestellt ist)? Gleiche Frage für Pin 6.

Gruß

Manfred


Fr 18. Jan 2019, 23:09
Profil
Beiträge der letzten Zeit anzeigen:  Sortiere nach  
Auf das Thema antworten   [ 3 Beiträge ] 

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 1 Gast


Du darfst keine neuen Themen in diesem Forum erstellen.
Du darfst keine Antworten zu Themen in diesem Forum erstellen.
Du darfst deine Beiträge in diesem Forum nicht ändern.
Du darfst deine Beiträge in diesem Forum nicht löschen.
Du darfst keine Dateianhänge in diesem Forum erstellen.

Suche nach:
Gehe zu:  
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group.
Designed by STSoftware for PTF.
Deutsche Übersetzung durch phpBB.de